Gloo Platform container images are scanned using Trivy for HIGH and CRITICAL vulnerabilities. To learn more about how Solo.io detects, tracks, and remediates CVEs, see CVE lifecycle handling.

Security and CVE scan

Latest 2.4.x gloo mesh enterprise Release: 2.4.2

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

No scan found

gloo mesh enterprise gloo-mesh-envoy image

No scan found

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No scan found

gloo mesh enterprise gloo-mesh-agent image

No scan found

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No scan found

gloo mesh enterprise gloo-mesh-istiod-agent image

No scan found

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No scan found

Release 2.4.1

gloo mesh enterprise gloo-mesh-spire-controller image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-spire-controller:2.4.1 (alpine 3.18.3)

Vulnerabilities Listed for usr/local/bin/spire-controller-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-ui:2.4.1 (alpine 3.17.5)

gloo mesh enterprise gloo-mesh-envoy image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-envoy:2.4.1 (ubuntu 20.04)

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.4.1 (alpine 3.18.3)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-28840github.com/docker/dockerHIGHv23.0.1+incompatible20.10.24, 23.0.3https://avd.aquasec.com/nvd/cve-2023-28840
CVE-2019-14993istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.4.1 (alpine 3.18.3)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-28840github.com/docker/dockerHIGHv23.0.1+incompatible20.10.24, 23.0.3https://avd.aquasec.com/nvd/cve-2023-28840
CVE-2019-14993istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.4.1 (alpine 3.18.3)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-28840github.com/docker/dockerHIGHv23.0.1+incompatible20.10.24, 23.0.3https://avd.aquasec.com/nvd/cve-2023-28840
CVE-2019-14993istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.4.1 (alpine 3.18.3)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-portal-server:2.4.1 (alpine 3.18.3)

Vulnerabilities Listed for usr/local/bin/portal-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20230824050558-a835e9cca9eb1.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
Release 2.4.0

gloo mesh enterprise gloo-mesh-spire-controller image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-spire-controller:2.4.0 (alpine 3.18.3)

Vulnerabilities Listed for usr/local/bin/spire-controller-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-ui:2.4.0 (alpine 3.17.5)

gloo mesh enterprise gloo-mesh-envoy image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-envoy:2.4.0 (ubuntu 20.04)

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.4.0 (alpine 3.18.3)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.4.0 (alpine 3.18.3)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.4.0 (alpine 3.18.3)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.4.0 (alpine 3.18.3)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-portal-server:2.4.0 (alpine 3.18.3)

Vulnerabilities Listed for usr/local/bin/portal-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20230403164233-3e857775086a1.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

Latest 2.3.x gloo mesh enterprise Release: 2.3.18

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

No scan found

gloo mesh enterprise gloo-mesh-envoy image

No scan found

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No scan found

gloo mesh enterprise gloo-mesh-agent image

No scan found

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No scan found

gloo mesh enterprise gloo-mesh-istiod-agent image

No scan found

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No scan found

Release 2.3.17

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-ui:2.3.17 (alpine 3.17.5)

gloo mesh enterprise gloo-mesh-envoy image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-envoy:2.3.17 (ubuntu 20.04)

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.3.17 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.3.17 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.3.17 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.3.17 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-portal-server:2.3.17 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/portal-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
Release 2.3.16

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-ui:2.3.16 (alpine 3.17.5)

gloo mesh enterprise gloo-mesh-envoy image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-envoy:2.3.16 (ubuntu 20.04)

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.3.16 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.3.16 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.3.16 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.3.16 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-portal-server:2.3.16 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/portal-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
Release 2.3.15

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-ui:2.3.15 (alpine 3.17.5)

gloo mesh enterprise gloo-mesh-envoy image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-envoy:2.3.15 (ubuntu 20.04)

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.3.15 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.3.15 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.3.15 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.3.15 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-portal-server:2.3.15 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/portal-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
Release 2.3.14

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-ui:2.3.14 (alpine 3.17.5)

gloo mesh enterprise gloo-mesh-envoy image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-envoy:2.3.14 (ubuntu 20.04)

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.3.14 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.3.14 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.3.14 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.3.14 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-portal-server:2.3.14 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/portal-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
Release 2.3.13

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-ui:2.3.13 (alpine 3.17.5)

gloo mesh enterprise gloo-mesh-envoy image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-envoy:2.3.13 (ubuntu 20.04)

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.3.13 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.3.13 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.3.13 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.3.13 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-portal-server:2.3.13 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/portal-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
Release 2.3.12

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-ui:2.3.12 (alpine 3.17.5)

gloo mesh enterprise gloo-mesh-envoy image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-envoy:2.3.12 (ubuntu 20.04)

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.3.12 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.3.12 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.3.12 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.3.12 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-portal-server:2.3.12 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/portal-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
Release 2.3.11

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-ui:2.3.11 (alpine 3.17.4)

gloo mesh enterprise gloo-mesh-envoy image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-envoy:2.3.11 (ubuntu 20.04)

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.3.11 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.3.11 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.3.11 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.3.11 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-portal-server:2.3.11 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/portal-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
Release 2.3.10

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-ui:2.3.10 (alpine 3.17.4)

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.3.10 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.3.10 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.3.10 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.3.10 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.3.10 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-portal-server:2.3.10 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/portal-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
Release 2.3.9

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.3.9 (alpine 3.17.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.3.9 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.3.9 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.3.9 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.3.9 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.3.9 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-portal-server:2.3.9 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/portal-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
Release 2.3.8

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.3.8 (alpine 3.17.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.3.8 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.3.8 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.3.8 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.3.8 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.3.8 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-portal-server:2.3.8 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/portal-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
Release 2.3.7

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.3.7 (alpine 3.17.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.3.7 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.3.7 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.3.7 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.3.7 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.3.7 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-portal-server:2.3.7 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/portal-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
Release 2.3.6

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.3.6 (alpine 3.17.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.3.6 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.3.6 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.3.6 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.3.6 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.3.6 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-portal-server:2.3.6 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/portal-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
Release 2.3.5

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.3.5 (alpine 3.17.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.3.5 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.3.5 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.3.5 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.3.5 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.3.5 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-portal-server:2.3.5 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/portal-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
Release 2.3.4

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.3.4 (alpine 3.17.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.3.4 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.3.4 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.3.4 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.3.4 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.3.4 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-portal-server:2.3.4 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/portal-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
Release 2.3.3

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.3.3 (alpine 3.17.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.3.3 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.3.3 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.3.3 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.3.3 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.3.3 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-portal-server:2.3.3 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/portal-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
Release 2.3.2

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.3.2 (alpine 3.17.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.3.2 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.3.2 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.3.2 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.3.2 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.3.2 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-portal-server:2.3.2 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/portal-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
Release 2.3.1

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.3.1 (alpine 3.17.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.3.1 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.3.1 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.3.1 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.3.1 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.3.1 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-portal-server:2.3.1 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/portal-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
Release 2.3.0

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.3.0 (alpine 3.17.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.3.0 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.3.0 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.3.0 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.3.0 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.3.0 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.12.31.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-portal-server:2.3.0 (alpine 3.17.1)

Vulnerabilities Listed for usr/local/bin/portal-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2019-14993istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20221208171804-952b2e8bc4b01.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

Latest 2.2.x gloo mesh enterprise Release: 2.2.9

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.2.9 (alpine 3.17.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464

gloo mesh enterprise gloo-mesh-envoy image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-envoy:2.2.9 (ubuntu 20.04)

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.2.9 (alpine 3.16.2)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2023-2253github.com/docker/distributionHIGHv2.8.1+incompatible2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2023-28840github.com/docker/dockerHIGHv20.10.16+incompatible20.10.24, 23.0.3https://avd.aquasec.com/nvd/cve-2023-28840
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.2.9 (alpine 3.16.2)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2023-2253github.com/docker/distributionHIGHv2.8.1+incompatible2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2023-28840github.com/docker/dockerHIGHv20.10.16+incompatible20.10.24, 23.0.3https://avd.aquasec.com/nvd/cve-2023-28840
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.2.9 (alpine 3.16.2)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2023-2253github.com/docker/distributionHIGHv2.8.1+incompatible2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2023-28840github.com/docker/dockerHIGHv20.10.16+incompatible20.10.24, 23.0.3https://avd.aquasec.com/nvd/cve-2023-28840
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.2.9 (alpine 3.16.2)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No scan found

Release 2.2.8

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.2.8 (alpine 3.17.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464

gloo mesh enterprise gloo-mesh-envoy image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-envoy:2.2.8 (ubuntu 20.04)

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.2.8 (alpine 3.16.2)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2023-2253github.com/docker/distributionHIGHv2.8.1+incompatible2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2023-28840github.com/docker/dockerHIGHv20.10.16+incompatible20.10.24, 23.0.3https://avd.aquasec.com/nvd/cve-2023-28840
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.2.8 (alpine 3.16.2)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2023-2253github.com/docker/distributionHIGHv2.8.1+incompatible2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2023-28840github.com/docker/dockerHIGHv20.10.16+incompatible20.10.24, 23.0.3https://avd.aquasec.com/nvd/cve-2023-28840
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.2.8 (alpine 3.16.2)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2023-2253github.com/docker/distributionHIGHv2.8.1+incompatible2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2023-28840github.com/docker/dockerHIGHv20.10.16+incompatible20.10.24, 23.0.3https://avd.aquasec.com/nvd/cve-2023-28840
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.2.8 (alpine 3.16.2)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No scan found

Release 2.2.7

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.2.7 (alpine 3.17.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464

gloo mesh enterprise gloo-mesh-envoy image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-envoy:2.2.7 (ubuntu 20.04)

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.2.7 (alpine 3.16.2)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2023-2253github.com/docker/distributionHIGHv2.8.1+incompatible2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2023-28840github.com/docker/dockerHIGHv20.10.16+incompatible20.10.24, 23.0.3https://avd.aquasec.com/nvd/cve-2023-28840
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.2.7 (alpine 3.16.2)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2023-2253github.com/docker/distributionHIGHv2.8.1+incompatible2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2023-28840github.com/docker/dockerHIGHv20.10.16+incompatible20.10.24, 23.0.3https://avd.aquasec.com/nvd/cve-2023-28840
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.2.7 (alpine 3.16.2)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2023-2253github.com/docker/distributionHIGHv2.8.1+incompatible2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2023-28840github.com/docker/dockerHIGHv20.10.16+incompatible20.10.24, 23.0.3https://avd.aquasec.com/nvd/cve-2023-28840
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.2.7 (alpine 3.16.2)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No scan found

Release 2.2.6

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.2.6 (alpine 3.17.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464

gloo mesh enterprise gloo-mesh-envoy image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-envoy:2.2.6 (ubuntu 20.04)

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.2.6 (alpine 3.16.2)

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2023-2253github.com/docker/distributionHIGHv2.8.1+incompatible2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2023-28840github.com/docker/dockerHIGHv20.10.16+incompatible20.10.24, 23.0.3https://avd.aquasec.com/nvd/cve-2023-28840
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-agent:2.2.6 (alpine 3.16.2)

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2023-2253github.com/docker/distributionHIGHv2.8.1+incompatible2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2023-28840github.com/docker/dockerHIGHv20.10.16+incompatible20.10.24, 23.0.3https://avd.aquasec.com/nvd/cve-2023-28840
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.2.6 (alpine 3.16.2)

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2023-2253github.com/docker/distributionHIGHv2.8.1+incompatible2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2023-28840github.com/docker/dockerHIGHv20.10.16+incompatible20.10.24, 23.0.3https://avd.aquasec.com/nvd/cve-2023-28840
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-istiod-agent image

No Vulnerabilities Found for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.2.6 (alpine 3.16.2)

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220606160615-c6abaf5e5fd61.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No scan found

Release 2.2.5

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.2.5 (alpine 3.17.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl3HIGH3.0.8-r03.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.2.5 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.2.5 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-agent:2.2.5 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.2.5 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.2.5 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No scan found

Release 2.2.4

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.2.4 (alpine 3.17.1)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0216libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0216
CVE-2023-0217libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0217
CVE-2023-0286libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0401libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0401
CVE-2023-0464libcrypto3HIGH3.0.7-r23.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0216libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0216
CVE-2023-0217libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0217
CVE-2023-0286libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0401libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0401
CVE-2023-0464libssl3HIGH3.0.7-r23.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.2.4 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.2.4 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-agent:2.2.4 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.2.4 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.2.4 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No scan found

Release 2.2.3

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.2.3 (alpine 3.17.1)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0216libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0216
CVE-2023-0217libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0217
CVE-2023-0286libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0401libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0401
CVE-2023-0464libcrypto3HIGH3.0.7-r23.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0216libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0216
CVE-2023-0217libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0217
CVE-2023-0286libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0401libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0401
CVE-2023-0464libssl3HIGH3.0.7-r23.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.2.3 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.2.3 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-agent:2.2.3 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.2.3 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.2.3 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0464libcrypto1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-0464libssl1.1HIGH1.1.1t-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2022-41723golang.org/x/netHIGHv0.5.00.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No scan found

Release 2.2.2

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.2.2 (alpine 3.17.1)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0216libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0216
CVE-2023-0217libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0217
CVE-2023-0286libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0401libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0401
CVE-2023-0464libcrypto3HIGH3.0.7-r23.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0216libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0216
CVE-2023-0217libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0217
CVE-2023-0286libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0401libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0401
CVE-2023-0464libssl3HIGH3.0.7-r23.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.2.2 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.2.2 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-agent:2.2.2 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.2.2 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.2.2 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No scan found

Release 2.2.1

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.2.1 (alpine 3.17.1)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0216libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0216
CVE-2023-0217libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0217
CVE-2023-0286libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0401libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0401
CVE-2023-0464libcrypto3HIGH3.0.7-r23.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0216libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0216
CVE-2023-0217libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0217
CVE-2023-0286libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0401libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0401
CVE-2023-0464libssl3HIGH3.0.7-r23.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.2.1 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.2.1 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-agent:2.2.1 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.2.1 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.2.1 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No scan found

Release 2.2.0

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.2.0 (alpine 3.16.3)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-23914curlCRITICAL7.83.1-r47.83.1-r6https://avd.aquasec.com/nvd/cve-2023-23914
CVE-2022-43551curlHIGH7.83.1-r47.83.1-r5https://avd.aquasec.com/nvd/cve-2022-43551
CVE-2023-27533curlHIGH7.83.1-r48.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27533
CVE-2023-27534curlHIGH7.83.1-r48.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27534
CVE-2023-28319curlHIGH7.83.1-r48.1.0-r0https://avd.aquasec.com/nvd/cve-2023-28319
CVE-2023-38039curlHIGH7.83.1-r48.3.0-r0https://avd.aquasec.com/nvd/cve-2023-38039
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-23914libcurlCRITICAL7.83.1-r47.83.1-r6https://avd.aquasec.com/nvd/cve-2023-23914
CVE-2022-43551libcurlHIGH7.83.1-r47.83.1-r5https://avd.aquasec.com/nvd/cve-2022-43551
CVE-2023-27533libcurlHIGH7.83.1-r48.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27533
CVE-2023-27534libcurlHIGH7.83.1-r48.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27534
CVE-2023-28319libcurlHIGH7.83.1-r48.1.0-r0https://avd.aquasec.com/nvd/cve-2023-28319
CVE-2023-38039libcurlHIGH7.83.1-r48.3.0-r0https://avd.aquasec.com/nvd/cve-2023-38039
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-1999libwebpHIGH1.2.3-r01.2.3-r1https://avd.aquasec.com/nvd/cve-2023-1999
CVE-2023-4863libwebpHIGH1.2.3-r01.2.3-r2https://avd.aquasec.com/nvd/cve-2023-4863
CVE-2023-29491ncurses-libsHIGH6.3_p20220521-r06.3_p20220521-r1https://avd.aquasec.com/nvd/cve-2023-29491
CVE-2023-29491ncurses-terminfo-baseHIGH6.3_p20220521-r06.3_p20220521-r1https://avd.aquasec.com/nvd/cve-2023-29491
CVE-2023-35945nghttp2-libsHIGH1.47.0-r01.47.0-r1https://avd.aquasec.com/nvd/cve-2023-35945
CVE-2022-41409pcre2HIGH10.40-r010.42-r0https://avd.aquasec.com/nvd/cve-2022-41409

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.2.0 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.2.0 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-agent:2.2.0 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.2.0 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.21.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.2.0 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No scan found

Latest 2.1.x gloo mesh enterprise Release: 2.1.5

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.1.5 (alpine 3.17.1)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0216libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0216
CVE-2023-0217libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0217
CVE-2023-0286libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0401libcrypto3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0401
CVE-2023-0464libcrypto3HIGH3.0.7-r23.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0216libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0216
CVE-2023-0217libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0217
CVE-2023-0286libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0401libssl3HIGH3.0.7-r23.0.8-r0https://avd.aquasec.com/nvd/cve-2023-0401
CVE-2023-0464libssl3HIGH3.0.7-r23.0.8-r1https://avd.aquasec.com/nvd/cve-2023-0464

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.1.5 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.1.5 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.11.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-agent:2.1.5 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.11.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.1.5 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.11.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.1.5 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No scan found

Release 2.1.4

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.1.4 (alpine 3.16.3)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-23914curlCRITICAL7.83.1-r47.83.1-r6https://avd.aquasec.com/nvd/cve-2023-23914
CVE-2022-43551curlHIGH7.83.1-r47.83.1-r5https://avd.aquasec.com/nvd/cve-2022-43551
CVE-2023-27533curlHIGH7.83.1-r48.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27533
CVE-2023-27534curlHIGH7.83.1-r48.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27534
CVE-2023-28319curlHIGH7.83.1-r48.1.0-r0https://avd.aquasec.com/nvd/cve-2023-28319
CVE-2023-38039curlHIGH7.83.1-r48.3.0-r0https://avd.aquasec.com/nvd/cve-2023-38039
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-23914libcurlCRITICAL7.83.1-r47.83.1-r6https://avd.aquasec.com/nvd/cve-2023-23914
CVE-2022-43551libcurlHIGH7.83.1-r47.83.1-r5https://avd.aquasec.com/nvd/cve-2022-43551
CVE-2023-27533libcurlHIGH7.83.1-r48.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27533
CVE-2023-27534libcurlHIGH7.83.1-r48.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27534
CVE-2023-28319libcurlHIGH7.83.1-r48.1.0-r0https://avd.aquasec.com/nvd/cve-2023-28319
CVE-2023-38039libcurlHIGH7.83.1-r48.3.0-r0https://avd.aquasec.com/nvd/cve-2023-38039
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-1999libwebpHIGH1.2.3-r01.2.3-r1https://avd.aquasec.com/nvd/cve-2023-1999
CVE-2023-4863libwebpHIGH1.2.3-r01.2.3-r2https://avd.aquasec.com/nvd/cve-2023-4863
CVE-2023-29491ncurses-libsHIGH6.3_p20220521-r06.3_p20220521-r1https://avd.aquasec.com/nvd/cve-2023-29491
CVE-2023-29491ncurses-terminfo-baseHIGH6.3_p20220521-r06.3_p20220521-r1https://avd.aquasec.com/nvd/cve-2023-29491
CVE-2023-35945nghttp2-libsHIGH1.47.0-r01.47.0-r1https://avd.aquasec.com/nvd/cve-2023-35945
CVE-2022-41409pcre2HIGH10.40-r010.42-r0https://avd.aquasec.com/nvd/cve-2022-41409

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.1.4 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.1.4 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.11.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-agent:2.1.4 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.11.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.1.4 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.11.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.1.4 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No scan found

Release 2.1.3

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.1.3 (alpine 3.16.3)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-23914curlCRITICAL7.83.1-r47.83.1-r6https://avd.aquasec.com/nvd/cve-2023-23914
CVE-2022-43551curlHIGH7.83.1-r47.83.1-r5https://avd.aquasec.com/nvd/cve-2022-43551
CVE-2023-27533curlHIGH7.83.1-r48.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27533
CVE-2023-27534curlHIGH7.83.1-r48.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27534
CVE-2023-28319curlHIGH7.83.1-r48.1.0-r0https://avd.aquasec.com/nvd/cve-2023-28319
CVE-2023-38039curlHIGH7.83.1-r48.3.0-r0https://avd.aquasec.com/nvd/cve-2023-38039
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-23914libcurlCRITICAL7.83.1-r47.83.1-r6https://avd.aquasec.com/nvd/cve-2023-23914
CVE-2022-43551libcurlHIGH7.83.1-r47.83.1-r5https://avd.aquasec.com/nvd/cve-2022-43551
CVE-2023-27533libcurlHIGH7.83.1-r48.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27533
CVE-2023-27534libcurlHIGH7.83.1-r48.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27534
CVE-2023-28319libcurlHIGH7.83.1-r48.1.0-r0https://avd.aquasec.com/nvd/cve-2023-28319
CVE-2023-38039libcurlHIGH7.83.1-r48.3.0-r0https://avd.aquasec.com/nvd/cve-2023-38039
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-1999libwebpHIGH1.2.3-r01.2.3-r1https://avd.aquasec.com/nvd/cve-2023-1999
CVE-2023-4863libwebpHIGH1.2.3-r01.2.3-r2https://avd.aquasec.com/nvd/cve-2023-4863
CVE-2023-29491ncurses-libsHIGH6.3_p20220521-r06.3_p20220521-r1https://avd.aquasec.com/nvd/cve-2023-29491
CVE-2023-29491ncurses-terminfo-baseHIGH6.3_p20220521-r06.3_p20220521-r1https://avd.aquasec.com/nvd/cve-2023-29491
CVE-2023-35945nghttp2-libsHIGH1.47.0-r01.47.0-r1https://avd.aquasec.com/nvd/cve-2023-35945
CVE-2022-41409pcre2HIGH10.40-r010.42-r0https://avd.aquasec.com/nvd/cve-2022-41409

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.1.3 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.1.3 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.11.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-agent:2.1.3 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.11.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.1.3 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.11.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.1.3 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No scan found

Release 2.1.2

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.1.2 (alpine 3.16.3)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-23914curlCRITICAL7.83.1-r47.83.1-r6https://avd.aquasec.com/nvd/cve-2023-23914
CVE-2022-43551curlHIGH7.83.1-r47.83.1-r5https://avd.aquasec.com/nvd/cve-2022-43551
CVE-2023-27533curlHIGH7.83.1-r48.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27533
CVE-2023-27534curlHIGH7.83.1-r48.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27534
CVE-2023-28319curlHIGH7.83.1-r48.1.0-r0https://avd.aquasec.com/nvd/cve-2023-28319
CVE-2023-38039curlHIGH7.83.1-r48.3.0-r0https://avd.aquasec.com/nvd/cve-2023-38039
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-23914libcurlCRITICAL7.83.1-r47.83.1-r6https://avd.aquasec.com/nvd/cve-2023-23914
CVE-2022-43551libcurlHIGH7.83.1-r47.83.1-r5https://avd.aquasec.com/nvd/cve-2022-43551
CVE-2023-27533libcurlHIGH7.83.1-r48.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27533
CVE-2023-27534libcurlHIGH7.83.1-r48.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27534
CVE-2023-28319libcurlHIGH7.83.1-r48.1.0-r0https://avd.aquasec.com/nvd/cve-2023-28319
CVE-2023-38039libcurlHIGH7.83.1-r48.3.0-r0https://avd.aquasec.com/nvd/cve-2023-38039
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-1999libwebpHIGH1.2.3-r01.2.3-r1https://avd.aquasec.com/nvd/cve-2023-1999
CVE-2023-4863libwebpHIGH1.2.3-r01.2.3-r2https://avd.aquasec.com/nvd/cve-2023-4863
CVE-2023-29491ncurses-libsHIGH6.3_p20220521-r06.3_p20220521-r1https://avd.aquasec.com/nvd/cve-2023-29491
CVE-2023-29491ncurses-terminfo-baseHIGH6.3_p20220521-r06.3_p20220521-r1https://avd.aquasec.com/nvd/cve-2023-29491
CVE-2023-35945nghttp2-libsHIGH1.47.0-r01.47.0-r1https://avd.aquasec.com/nvd/cve-2023-35945
CVE-2022-41409pcre2HIGH10.40-r010.42-r0https://avd.aquasec.com/nvd/cve-2022-41409

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.1.2 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.1.2 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.11.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-agent:2.1.2 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.11.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.1.2 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.11.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.1.2 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No scan found

Release 2.1.1

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.1.1 (alpine 3.16.1)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-32221curlCRITICAL7.83.1-r27.83.1-r4https://avd.aquasec.com/nvd/cve-2022-32221
CVE-2023-23914curlCRITICAL7.83.1-r27.83.1-r6https://avd.aquasec.com/nvd/cve-2023-23914
CVE-2022-42915curlHIGH7.83.1-r27.83.1-r4https://avd.aquasec.com/nvd/cve-2022-42915
CVE-2022-42916curlHIGH7.83.1-r27.83.1-r4https://avd.aquasec.com/nvd/cve-2022-42916
CVE-2022-43551curlHIGH7.83.1-r27.83.1-r5https://avd.aquasec.com/nvd/cve-2022-43551
CVE-2023-27533curlHIGH7.83.1-r28.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27533
CVE-2023-27534curlHIGH7.83.1-r28.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27534
CVE-2023-28319curlHIGH7.83.1-r28.1.0-r0https://avd.aquasec.com/nvd/cve-2023-28319
CVE-2023-38039curlHIGH7.83.1-r28.3.0-r0https://avd.aquasec.com/nvd/cve-2023-38039
CVE-2022-4450libcrypto1.1HIGH1.1.1q-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1q-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1q-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1q-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-32221libcurlCRITICAL7.83.1-r27.83.1-r4https://avd.aquasec.com/nvd/cve-2022-32221
CVE-2023-23914libcurlCRITICAL7.83.1-r27.83.1-r6https://avd.aquasec.com/nvd/cve-2023-23914
CVE-2022-42915libcurlHIGH7.83.1-r27.83.1-r4https://avd.aquasec.com/nvd/cve-2022-42915
CVE-2022-42916libcurlHIGH7.83.1-r27.83.1-r4https://avd.aquasec.com/nvd/cve-2022-42916
CVE-2022-43551libcurlHIGH7.83.1-r27.83.1-r5https://avd.aquasec.com/nvd/cve-2022-43551
CVE-2023-27533libcurlHIGH7.83.1-r28.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27533
CVE-2023-27534libcurlHIGH7.83.1-r28.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27534
CVE-2023-28319libcurlHIGH7.83.1-r28.1.0-r0https://avd.aquasec.com/nvd/cve-2023-28319
CVE-2023-38039libcurlHIGH7.83.1-r28.3.0-r0https://avd.aquasec.com/nvd/cve-2023-38039
CVE-2022-4450libssl1.1HIGH1.1.1q-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1q-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1q-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1q-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-1999libwebpHIGH1.2.3-r01.2.3-r1https://avd.aquasec.com/nvd/cve-2023-1999
CVE-2023-4863libwebpHIGH1.2.3-r01.2.3-r2https://avd.aquasec.com/nvd/cve-2023-4863
CVE-2022-2309libxml2HIGH2.9.14-r02.9.14-r1https://avd.aquasec.com/nvd/cve-2022-2309
CVE-2022-40303libxml2HIGH2.9.14-r02.9.14-r2https://avd.aquasec.com/nvd/cve-2022-40303
CVE-2022-40304libxml2HIGH2.9.14-r02.9.14-r2https://avd.aquasec.com/nvd/cve-2022-40304
CVE-2023-29491ncurses-libsHIGH6.3_p20220521-r06.3_p20220521-r1https://avd.aquasec.com/nvd/cve-2023-29491
CVE-2023-29491ncurses-terminfo-baseHIGH6.3_p20220521-r06.3_p20220521-r1https://avd.aquasec.com/nvd/cve-2023-29491
CVE-2023-35945nghttp2-libsHIGH1.47.0-r01.47.0-r1https://avd.aquasec.com/nvd/cve-2023-35945
CVE-2022-41409pcre2HIGH10.40-r010.42-r0https://avd.aquasec.com/nvd/cve-2022-41409
CVE-2022-37434zlibCRITICAL1.2.12-r11.2.12-r2https://avd.aquasec.com/nvd/cve-2022-37434

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.1.1 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.1.1 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.11.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-agent:2.1.1 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.11.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.1.1 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.11.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.1.1 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No scan found

Release 2.1.0

gloo mesh enterprise gloo-mesh-spire-controller image

No scan found

gloo mesh enterprise enterprise-agent image

No scan found

gloo mesh enterprise gloo-mesh-ui image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-ui:2.1.0 (alpine 3.16.1)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-32221curlCRITICAL7.83.1-r27.83.1-r4https://avd.aquasec.com/nvd/cve-2022-32221
CVE-2023-23914curlCRITICAL7.83.1-r27.83.1-r6https://avd.aquasec.com/nvd/cve-2023-23914
CVE-2022-42915curlHIGH7.83.1-r27.83.1-r4https://avd.aquasec.com/nvd/cve-2022-42915
CVE-2022-42916curlHIGH7.83.1-r27.83.1-r4https://avd.aquasec.com/nvd/cve-2022-42916
CVE-2022-43551curlHIGH7.83.1-r27.83.1-r5https://avd.aquasec.com/nvd/cve-2022-43551
CVE-2023-27533curlHIGH7.83.1-r28.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27533
CVE-2023-27534curlHIGH7.83.1-r28.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27534
CVE-2023-28319curlHIGH7.83.1-r28.1.0-r0https://avd.aquasec.com/nvd/cve-2023-28319
CVE-2023-38039curlHIGH7.83.1-r28.3.0-r0https://avd.aquasec.com/nvd/cve-2023-38039
CVE-2022-4450libcrypto1.1HIGH1.1.1q-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1q-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1q-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1q-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-32221libcurlCRITICAL7.83.1-r27.83.1-r4https://avd.aquasec.com/nvd/cve-2022-32221
CVE-2023-23914libcurlCRITICAL7.83.1-r27.83.1-r6https://avd.aquasec.com/nvd/cve-2023-23914
CVE-2022-42915libcurlHIGH7.83.1-r27.83.1-r4https://avd.aquasec.com/nvd/cve-2022-42915
CVE-2022-42916libcurlHIGH7.83.1-r27.83.1-r4https://avd.aquasec.com/nvd/cve-2022-42916
CVE-2022-43551libcurlHIGH7.83.1-r27.83.1-r5https://avd.aquasec.com/nvd/cve-2022-43551
CVE-2023-27533libcurlHIGH7.83.1-r28.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27533
CVE-2023-27534libcurlHIGH7.83.1-r28.0.1-r0https://avd.aquasec.com/nvd/cve-2023-27534
CVE-2023-28319libcurlHIGH7.83.1-r28.1.0-r0https://avd.aquasec.com/nvd/cve-2023-28319
CVE-2023-38039libcurlHIGH7.83.1-r28.3.0-r0https://avd.aquasec.com/nvd/cve-2023-38039
CVE-2022-4450libssl1.1HIGH1.1.1q-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1q-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1q-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1q-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2023-1999libwebpHIGH1.2.3-r01.2.3-r1https://avd.aquasec.com/nvd/cve-2023-1999
CVE-2023-4863libwebpHIGH1.2.3-r01.2.3-r2https://avd.aquasec.com/nvd/cve-2023-4863
CVE-2022-2309libxml2HIGH2.9.14-r02.9.14-r1https://avd.aquasec.com/nvd/cve-2022-2309
CVE-2022-40303libxml2HIGH2.9.14-r02.9.14-r2https://avd.aquasec.com/nvd/cve-2022-40303
CVE-2022-40304libxml2HIGH2.9.14-r02.9.14-r2https://avd.aquasec.com/nvd/cve-2022-40304
CVE-2023-29491ncurses-libsHIGH6.3_p20220521-r06.3_p20220521-r1https://avd.aquasec.com/nvd/cve-2023-29491
CVE-2023-29491ncurses-terminfo-baseHIGH6.3_p20220521-r06.3_p20220521-r1https://avd.aquasec.com/nvd/cve-2023-29491
CVE-2023-35945nghttp2-libsHIGH1.47.0-r01.47.0-r1https://avd.aquasec.com/nvd/cve-2023-35945
CVE-2022-41409pcre2HIGH10.40-r010.42-r0https://avd.aquasec.com/nvd/cve-2022-41409
CVE-2022-37434zlibCRITICAL1.2.12-r11.2.12-r2https://avd.aquasec.com/nvd/cve-2022-37434

gloo mesh enterprise gloo-mesh-envoy image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-envoy:2.1.0 (ubuntu 18.04)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-0286libssl1.1HIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0286opensslHIGH1.1.1-1ubuntu2.1~18.04.201.1.1-1ubuntu2.1~18.04.21https://avd.aquasec.com/nvd/cve-2023-0286

gloo mesh enterprise rbac-webhook image

No scan found

gloo mesh enterprise gloo-mesh-mgmt-server image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-mgmt-server:2.1.0 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/mgmt-server-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.11.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-mesh-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-agent:2.1.0 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.11.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise enterprise-networking image

No scan found

gloo mesh enterprise gloo-mesh-apiserver image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-apiserver:2.1.0 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/apiserver-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2021-21272github.com/deislabs/orasHIGHv0.8.10.9.0https://avd.aquasec.com/nvd/cve-2021-21272
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2017-11468github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.7.0-rc.0https://avd.aquasec.com/nvd/cve-2017-11468
CVE-2023-2253github.com/docker/distributionHIGHv0.0.0-20191216044856-a8371794149d2.8.2-beta.1https://avd.aquasec.com/nvd/cve-2023-2253
CVE-2022-37315github.com/graphql-go/graphqlHIGHv0.8.00.8.1https://avd.aquasec.com/nvd/cve-2022-37315
CVE-2014-9356github.com/moby/mobyHIGHv0.7.3-0.20190826074503-38ab9da003091.3.3https://avd.aquasec.com/nvd/cve-2014-9356
CVE-2023-27561github.com/opencontainers/runcHIGHv1.1.11.1.5https://avd.aquasec.com/nvd/cve-2023-27561
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635
CVE-2020-8558k8s.io/kubernetesHIGHv1.13.01.18.4, 1.17.7, 1.16.11https://avd.aquasec.com/nvd/cve-2020-8558
CVE-2021-25741k8s.io/kubernetesHIGHv1.13.01.19.15, 1.20.11, 1.21.5, 1.22.2https://avd.aquasec.com/nvd/cve-2021-25741

gloo mesh enterprise gloo-mesh-istiod-agent image

Vulnerabilities Listed for gcr.io/gloo-mesh/gloo-mesh-istiod-agent:2.1.0 (alpine 3.16.2)

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2022-4450libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libcrypto1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libcrypto1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464
CVE-2022-4450libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2022-4450
CVE-2023-0215libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0215
CVE-2023-0286libssl1.1HIGH1.1.1s-r01.1.1t-r0https://avd.aquasec.com/nvd/cve-2023-0286
CVE-2023-0464libssl1.1HIGH1.1.1s-r01.1.1t-r1https://avd.aquasec.com/nvd/cve-2023-0464

Vulnerabilities Listed for usr/local/bin/istiod-agent-linux-amd64

Vulnerability IDPackageSeverityInstalled VersionFixed VersionReference
CVE-2023-29002github.com/cilium/ciliumHIGHv1.11.51.11.16, 1.12.9, 1.13.2https://avd.aquasec.com/nvd/cve-2023-29002
CVE-2020-26160github.com/dgrijalva/jwt-goHIGHv3.2.0+incompatiblehttps://avd.aquasec.com/nvd/cve-2020-26160
CVE-2022-27664golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.0.0-20220906165146-f3363e06e74chttps://avd.aquasec.com/nvd/cve-2022-27664
CVE-2022-41721golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.1.1-0.20221104162952-702349b0e862https://avd.aquasec.com/nvd/cve-2022-41721
CVE-2022-41723golang.org/x/netHIGHv0.0.0-20220722155237-a158d28d115b0.7.0https://avd.aquasec.com/nvd/cve-2022-41723
CVE-2022-32149golang.org/x/textHIGHv0.3.70.3.8https://avd.aquasec.com/nvd/cve-2022-32149
CVE-2019-14993istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.1.13, 1.2.4https://avd.aquasec.com/nvd/cve-2019-14993
CVE-2021-39155istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39155
CVE-2021-39156istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.9.8, 1.10.4, 1.11.1https://avd.aquasec.com/nvd/cve-2021-39156
CVE-2022-23635istio.io/istioHIGHv0.0.0-20220516185659-202e888638581.13.1, 1.12.4, 1.11.7https://avd.aquasec.com/nvd/cve-2022-23635

gloo mesh enterprise gloo-otel-controller image

No scan found

gloo mesh enterprise gloo-mesh-portal-server image

No scan found